x64 Driver Bug

This is the English forum for all topics related to IO-Warrior. Please post in English only

Moderator: Guido Körber

phoenix
Beiträge: 17
Registriert: Mi Mai 02, 2007 1:10 pm

x64 Driver Bug

Beitragvon phoenix » So Aug 14, 2011 6:07 am

I think I've found a big in the IOWarrior x64 driver

I use the processor Serial number as part of my software security, this has worked pretty well in all x86 installations, however, Im now finding that in x64 installations the serial number shows up as 0.

Con someone confirm if this is a bug, or if there is a easy fix in my software that will resolve this.

Thanks

Bryan
Guido Körber
Site Admin
Beiträge: 3220
Registriert: Di Nov 25, 2003 10:25 pm
Wohnort: Germany/Berlin
Kontaktdaten:

Re: x64 Driver Bug

Beitragvon Guido Körber » Mi Aug 17, 2011 1:56 pm

Our Windows guy will be back in the office on Monday, right now I can't verify this.
Benutzeravatar
Christoph Jung
Beiträge: 571
Registriert: So Okt 08, 2006 3:43 pm
Wohnort: Germany / Berlin
Kontaktdaten:

Re: x64 Driver Bug

Beitragvon Christoph Jung » Di Aug 23, 2011 12:58 pm

I've test my x86 application (with x86 DLL) on my x64 Windows 7 without any problems. I get the serialnumber from the device.
Do you use a x86 or x64 Application / DLL on your x64 system?
Abteilung: Softwareentwicklung
Folge uns auf Twitter
Follow us on twitter
phoenix
Beiträge: 17
Registriert: Mi Mai 02, 2007 1:10 pm

Re: x64 Driver Bug

Beitragvon phoenix » Do Sep 01, 2011 12:05 am

its an x86 application written in VB.NET 2010, using the x64 driver

It doesn't matter if I build it inside an x86 or x64 OS I get the same error, I've tried rebuilding and debugging inside x64 OS and can see that the array that returns the serial code only contains a value of 41 in one of the bytes with the rest being returned as zero
Benutzeravatar
Christoph Jung
Beiträge: 571
Registriert: So Okt 08, 2006 3:43 pm
Wohnort: Germany / Berlin
Kontaktdaten:

Re: x64 Driver Bug

Beitragvon Christoph Jung » Do Sep 01, 2011 10:13 am

Could you send my the application and the project from Visual Studio. I will take a look on it.
Send it as a ZIP-File to jung@codemercs.com
Abteilung: Softwareentwicklung
Folge uns auf Twitter
Follow us on twitter
phoenix
Beiträge: 17
Registriert: Mi Mai 02, 2007 1:10 pm

Re: x64 Driver Bug

Beitragvon phoenix » Do Sep 01, 2011 10:23 am

Hm..... the project in question is pretty big and ugly, let me see if I can replicate the problem in one of my other projects
phoenix
Beiträge: 17
Registriert: Mi Mai 02, 2007 1:10 pm

Re: x64 Driver Bug

Beitragvon phoenix » Do Sep 01, 2011 11:49 am

OK, well that didn't go as planned!

Firstly I didn't have a suitable project so made one using the core code from the problem project....only for it to work!!!

Went back to the original project and stripped that down to the core code, and nothing I did would work, I ended up deleting 95% of the code and it still wouldn't work!

Having ruled out the code I started looking at the configuration, and found the problem, and solution

Basically you must use .NET framework 4.0, the problem project was .NET 3.5, as soon as I changed it to 4.0 the problem was solved

preparat alveo http://www.alveo-akuna.pl

Zurück zu „IO-Warrior English“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast