SpinWarrior24R4 nach Booten (XP) sendet "Stör"-Codes ?

Dies ist das deutsche Forum für alle Themen um den SpinWarrior. Beiträge bitte nur in Deutsch.

Moderator: Guido Körber

Hubauer
Beiträge: 21
Registriert: So Sep 26, 2010 2:10 pm

SpinWarrior24R4 nach Booten (XP) sendet "Stör"-Codes ?

Beitragvon Hubauer » Mo Sep 27, 2010 9:56 am

Ich verwende in einem System unter Windows XP

1 Keywarrior Commander 16x8 - Platinenlayout nach Datenblatt jedoch nicht alle Pins der Matrix angeschlossen

1 Spinwarrior24R4 - Platinenlayout nach Datenblatt, 4 mechanische Encoder - C an E/N , 2 Taster an GND

Nach dem Booten wird unter Autostart die Anwendung SpinControl zum Erzeugen von Tastaturcodes aufgerufen. Normalerweise funktioniert das prima.
Von Zeit zu Zeit werden jedoch am Ende des Bootvorgangs von XP (Desktop bereits vorhanden) unkontrolliert und in schneller Folge Codes wie "Alt-Tab" ,... aufgerufen und das System blockiert. Die Störung deutet auf die unter SpinControl hinterlegten Tastaturcodes hin.

Bitte um Tipps für die Fehlersuche
Benutzeravatar
Christoph Jung
Beiträge: 560
Registriert: So Okt 08, 2006 3:43 pm
Wohnort: Germany / Berlin
Kontaktdaten:

Re: SpinWarrior24R4 nach Booten (XP) sendet "Stör"-Codes ?

Beitragvon Christoph Jung » Mo Sep 27, 2010 10:14 am

Ich hatte das Programm über 1 Jahr im Betrieb und hatte nie solche Probleme.
Ist das ein Reproduzierbares Phänomen oder ist das eher Sporadisch?
Was sagt der Event-Logger von Windows wenn so etwas passiert?
Liegt evtl. ein Hardwarefehler vor, also ein Kurzschluss oder sowas?
Abteilung: Softwareentwicklung
Folge uns auf Twitter
Follow us on twitter
Hubauer
Beiträge: 21
Registriert: So Sep 26, 2010 2:10 pm

Re: SpinWarrior24R4 nach Booten (XP) sendet "Stör"-Codes ?

Beitragvon Hubauer » Di Sep 28, 2010 9:11 am

Ich habe unterdessen diverse Tests unternommen. Bisher erfolgreich waren folgende Änderungen

- Ordnen/Verzögern der Anwendungen im Autostart
dabei Start
* vorletzte Anwendung - umfassendes Script, das auch Keycodes erzeugt (auf Basis Autohotkey)
* letzte Anwendung - Spincontroller

- Abschalten von ctfmon.exe im Autostart

Die eigentliche Ursache habe ich noch nicht analysieren können. Vorläufige Schlussfolgerungen:

- Spincontroller selbst ist wohl nicht die Ursache
- möglicherweise liegt es an der Kombination von Spincontroller mit dem anderen Script
- Vermutung: ctfmon.exe ist Teil des Problems

preparat alveo http://www.alveo-akuna.pl

Zurück zu „SpinWarrior Deutsch“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast