SPI explizizes Rücksetzen des SS ohne Zeichen zu senden.

Dies ist das deutsche Forum für alle Themen um den IO-Warrior. Beiträge bitte nur in Deutsch.

Moderator: Guido Körber

Post Reply
ofreddy
Posts: 1
Joined: Mon Oct 12, 2015 8:49 am

SPI explizizes Rücksetzen des SS ohne Zeichen zu senden.

Post by ofreddy »

Hallo zusammen.

ich möchte eine bestehende Applikation durch Anpassung der HAL Schicht auf einen IOWarrior56 umsetzen.
Aus der Applikation wird eine unbestimmte Anzahl von Zeichen in möglicherweise mehreren Aufrufe der Sendemethode segmentiert.
Hierbei kann ich durch Setzen des SSActive Flags im Report verhindern, dass die SS Leitung wieder inaktiv wird.
Danach kommt aus der Applikation der Aufruf einer weiteren Methode die keine Zeichen mehr überträgt sondern nur das SS Signal deaktivieren soll.

Ich habe versucht die Methode IowKitWrite mit deaktiviertem SSActive und Count=0 aufzurufen. Dieser Aufruf gibt als Rückgabewert eine 0 zurück.
Die SS Leitung bleibt aktiv. Rufe ich hier IowKitWrite mit Count=1 und einem Dummy Byte auf funktioniert das Rücksetzen der SS Leitung zwar,
jedoch gerät mein SPI Slave dann aber sporadisch durch das Extra Byte in seltsame Zustände.

Gibt es eine Möglichkeit die SS Leitung zu deaktivieren ohne weitere Zeichen zu übertragen?

Danke für eine Unterstützung im Voraus.

User avatar
Christoph Jung
Posts: 628
Joined: Sun Oct 08, 2006 3:43 pm
Location: Germany / Berlin
Contact:

Re: SPI explizizes Rücksetzen des SS ohne Zeichen zu senden.

Post by Christoph Jung »

Ich schätze der SPI-Slave wird das Byte, was zum deaktivieren verwendt wird, verwerten und so den Unsinn erzeugen.
Ist es denn nicht mögich vor dem Senden alle Daten zu holen und dann alles auf einmal zu senden?
Abteilung: Softwareentwicklung
Folge uns auf Twitter
Follow us on twitter

Post Reply