Seltsames Verhalten an einem Tablet

Dies ist das deutsche Forum für alle Themen um den IO-Warrior. Beiträge bitte nur in Deutsch.

Moderator: Guido Körber

Post Reply
Franz Peter Zantis
Posts: 97
Joined: Wed Aug 03, 2011 3:46 pm
Contact:

Seltsames Verhalten an einem Tablet

Post by Franz Peter Zantis »

Ich schreibe hier weil ich mir vorstellen kann, dass schon jemand dieses Problem hatte und es lösen konnte.

Ich habe ein Programm entwickelt für ein Projekt mit dem IO-Warrior56 (IOW56-MOD V2.0.0.2 R). Für die Entwicklung habe ich ein Notebook Lenovo T420 eingesetzt. Alles funktioniert prima.
Nach ausgiebigen Tests habe ich das Programm dann auf ein Tablet (auf dem das Programm dann endgültig laufen soll) übertragen. Dort verhält sich das Programm sehr seltsam. Zwischen der Ausführung hält es an und alle Pins des IO-Warrior56 springen kurz mal auf auf high (ca. 20....500 ms). Dann läuft es weiter. Ich habe mir die USB-Datenleitungen auf einem Oszilloskop angesehen und festgestellt, dass das Springen auf High korreliert mit einem Low auf der D+-Leitung. Die D+ - Leitung springt zwischendurch immer mal für ca. 20 bis 500 ms auf low. Die Kommunikation steht dann still und die Pins des IO-Warrior springen auf High. Ich habe dann ein zweites Tablet verwendet (gleicher Typ Acer Iconia W3) - es zeigt das gleiche verhalten.
Die USB-Leitung versorgt gleichzeitig die IO-Warrior-Schaltung mit Spannung. Der Stromaufnahme liegt jedoch nur bei ca. 50 mA. Ich habe trotzdem den IO-Warrior56 dann für den Hochstrom-Modus (500 mA) verschaltet (Pin 6.0 auf High über 6,8 kOhm). Aber das brachte keinen Unterschied.

Wer hatte so etwas schon einmal?
In früheren Projekten mit dem gleichen Tablet aber dem alten IO-Warrior56 (IOW56-MOD V1.xxxx) hatte ich solch ein Problem noch nicht. Diese Projekte laufen seit Jahren.

Viele Grüße
Franz Peter Zantis
Guido Körber
Site Admin
Posts: 2764
Joined: Tue Nov 25, 2003 10:25 pm
Location: Germany/Berlin
Contact:

Re: Seltsames Verhalten an einem Tablet

Post by Guido Körber »

Ist D- zu dem Zeitpunkt auch auf Low? Dann wäre das das sogenannte "single ended zero", was auf dem USB das Reset-Signal ist.
Das Problem liegt da auf der Host-Seite, wahrscheinlich ein komischer Treiber, oder völlig irre Grundeinstellungen des Systems.
User avatar
Christoph Jung
Posts: 632
Joined: Sun Oct 08, 2006 3:43 pm
Location: Germany / Berlin
Contact:

Re: Seltsames Verhalten an einem Tablet

Post by Christoph Jung »

Ich habe hier ein Teclast Windows 10 Tablett ab und an im Betrieb und hatte das Problem bisher nicht.
Was heißst denn "zwischen der Ausführung"? Bedeutet das wärend das Programm läuft oder wen das Programm, was auf den
IO-Warrior zugreift beendet uns wieder gestartet wird, bzw. IowKitClose() aufgerugen wird?
Abteilung: Softwareentwicklung
Folge uns auf Twitter
Follow us on twitter
Post Reply