JoyWarrior24F8 reports wrong Y angle with Tiltsensor

This is the English forum for all topics related to JoyWarrior. Please post in English only

Moderator: Guido Körber

Post Reply
Alfredo
Posts: 4
Joined: Thu Feb 05, 2009 11:11 am

JoyWarrior24F8 reports wrong Y angle with Tiltsensor

Post by Alfredo »

I have purchased a Joywarrior24F8 accelerometer and I tested the angles with your program Tiltsensor.exe.
Everything was fine, in particular when the Y axis was flat horizontal I got a reading of 000 and 0.02°, and when vertical the reading was 256 and 89° approximately.
Then I tried your program Calibration.exe. I put the JoyWarrior flat and without moving it I pushed the "Zero" button of the program. After this I went back to the Tiltsensor.exe program and I was surprised to see that the Y axis, when tilted vertical, was reading 112 and 26°. No matter what movement I made the angle was never above 26°. The X and Z axis were behaving normally as before the calibration. I repeated many times the calibration but the problem remains: when vertical the Y axis always reads around 26°.
Can you help?
Regards,
Alfredo
Guido Körber
Site Admin
Posts: 2766
Joined: Tue Nov 25, 2003 10:25 pm
Location: Germany/Berlin
Contact:

Re: JoyWarrior24F8 reports wrong Y angle with Tiltsensor

Post by Guido Körber »

Possibly you have changed the measurement range of the sensor, the tilt program assumes the sensor to by in the +/-2g range. Use the programming tool to check and set the range.
User avatar
Christoph Jung
Posts: 632
Joined: Sun Oct 08, 2006 3:43 pm
Location: Germany / Berlin
Contact:

Re: JoyWarrior24F8 reports wrong Y angle with Tiltsensor

Post by Christoph Jung »

Have you still running both applications at the same time? The applications interrupts themself if the work side by side. If you wnt to calibrate it, close all other JW24F8-Apps and then start the calibration. If you want to use the tilt-application do it in the same way.
Abteilung: Softwareentwicklung
Folge uns auf Twitter
Follow us on twitter
Alfredo
Posts: 4
Joined: Thu Feb 05, 2009 11:11 am

Re: JoyWarrior24F8 reports wrong Y angle with Tiltsensor

Post by Alfredo »

Thank you Cristoph and Guido for your suggestions but my problem is still there: with tiltsensor the range of the Y axis is limited between 0 (horizontal) and 26° (vertical) and the readings span from 0 to a maximum of 112. The X axis is ok ranging from 0 to 90° and also the Z axis looks ok with readings from 0 (vertical) to 256 (horizontal). I have checked the range as Guido suggests with the programming tool and the range is +/- 2G and I am always using one program at a time.
Is my unit defective?
User avatar
Christoph Jung
Posts: 632
Joined: Sun Oct 08, 2006 3:43 pm
Location: Germany / Berlin
Contact:

Re: JoyWarrior24F8 reports wrong Y angle with Tiltsensor

Post by Christoph Jung »

I have create a simpla application to read the calibration-values:
http://www.codemercs.de/uploads/tx_sbdo ... nfo_01.zip

Please use it and tell us the values from GAIN and Offset.

If the range or bandwidth is not 2G 50Hz please change them with the AS-Programmer tool. This is not nessasary for read the calibration!
Abteilung: Softwareentwicklung
Folge uns auf Twitter
Follow us on twitter
Alfredo
Posts: 4
Joined: Thu Feb 05, 2009 11:11 am

Re: JoyWarrior24F8 reports wrong Y angle with Tiltsensor

Post by Alfredo »

Cristoph,
here are the values that I get using your jw24f8info program:

Range: +/- 2G
Bandwith: 50Hz

Offset Gain

X 0x312 0x02C

Y 0x28D 0x001

Z 0x296 0x02D
User avatar
Christoph Jung
Posts: 632
Joined: Sun Oct 08, 2006 3:43 pm
Location: Germany / Berlin
Contact:

Re: JoyWarrior24F8 reports wrong Y angle with Tiltsensor

Post by Christoph Jung »

The gain-value of Y looks to be incorrect. But i don't understand why, because we don't write into the reigsters with the calibration tool.
Have you run another JW24F8 application t the first calibration?
Abteilung: Softwareentwicklung
Folge uns auf Twitter
Follow us on twitter
Alfredo
Posts: 4
Joined: Thu Feb 05, 2009 11:11 am

Re: JoyWarrior24F8 reports wrong Y angle with Tiltsensor

Post by Alfredo »

I am not sure that I understand your question, Christoph.
I own two Jw24F8: one is the qcn kit that I bought from you. I have calibrated it with the calibration tool and this one works well and is now dedicated to the qcn network. I then bought a second one: and this is the one that initially worked well but then I performed a calibration with the calibration tool and from that moment the Y axis started to have a limited range. I tried to calibrate it again several times but with no result.
Anyway can the register Y value be corrected? if so how?
Guido Körber
Site Admin
Posts: 2766
Joined: Tue Nov 25, 2003 10:25 pm
Location: Germany/Berlin
Contact:

Re: JoyWarrior24F8 reports wrong Y angle with Tiltsensor

Post by Guido Körber »

The question is if you had another application running that was using the JW24F8 when you started the calibration tool. We are trying to establish how this could have happened, our tools deliberately do not touch the gain values for the axes.

Yes, it is possible to reset this, we do have a version of the calibration tool that allows write access to the gain values, initially we had shipped that as the only version but we had too many people who decalibrated their sensors by playing with the gain values.
User avatar
Christoph Jung
Posts: 632
Joined: Sun Oct 08, 2006 3:43 pm
Location: Germany / Berlin
Contact:

Re: JoyWarrior24F8 reports wrong Y angle with Tiltsensor

Post by Christoph Jung »

Alfredo please send me an E-Mail to jung(at)codemercs(dot)com and i will send you the calibration tool with changeables gain via e-mail.
Abteilung: Softwareentwicklung
Folge uns auf Twitter
Follow us on twitter
Post Reply